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Chapter 830

Tolerance Intervals for
Normal Data
Introduction
This routine calculates the sample size needed to obtain a specified coverage of a β-content tolerance interval at a
stated confidence level for data from the normal distribution and data without a specified distribution. These
intervals are constructed so that they contain at least 100β% of the population with probability of at least 100(1 α)%. For example, in water management, a drinking water standard might be that one is 95% confident that
certain chemical concentrations are not exceeded more than 3% of the time.

Difference between a Confidence Interval and a Tolerance Interval
It is easy to get confused about the difference between a confidence interval and a tolerance interval. Just
remember than a confidence interval is usually a probability statement about the value of a distributional
parameter such as the mean or proportion. On the other hand, a tolerance interval is a probability statement about
a proportion of the distribution from which the sample is drawn.

Technical Details
This section is primarily based on results in Guenther (1977). Other useful references are Guenther (1972), Hahn
and Meeker (1991), Howe (1969), Krishnamoorthy and Mathew (2009), Odeh, Chou, and Owen (1987), and
Young, Gordon, Zhu, and Olin (2016).
A tolerance interval is constructed from a random sample so that a specified proportion of the population is
contained within the interval. The interval is defined by two limits, L1 and L2, which are constructed using
𝐿𝐿1 = 𝑥𝑥̅ − 𝑘𝑘𝑘𝑘, 𝐿𝐿2 = 𝑥𝑥̅ + 𝑘𝑘𝑘𝑘

where 𝑥𝑥̅ is the sample mean, s is the sample standard deviation, and k is calculated as described below.

Proportion of the Population Covered

An important concept is that of coverage. Coverage is the proportion of the population distribution that is between
the two limits. For the normal distribution, these population limits are defined by
𝜇𝜇 ± 𝑧𝑧𝛼𝛼/2 𝜎𝜎

The coverage is the area under the standard normal distribution between these limits.
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Solving for N
The tolerance factor k is constructed so that
Pr(𝐿𝐿2 − 𝐿𝐿1 ≥ 𝑃𝑃) = 1 − 𝛼𝛼

Guenther (1977) provides the following approximation for k in the two-sided case
𝑘𝑘 = 𝑢𝑢𝑢𝑢𝑢𝑢

where
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Using this value of k, the minimum value of N is found by increasing N by one at each iteration and stopping
when
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Guenther (1977) also provides an algorithm for finding N in the one-sided case.
𝑘𝑘1 =

Where T’ is the noncentral T distribution.

𝑘𝑘2 =

Starting at N = 2, increase N by one until k1 ≤ k2.
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Procedure Options
This section describes the options that are specific to this procedure. These are located on the Design tab. For
more information about the options of other tabs, go to the Procedure Window chapter.

Design Tab
The Design tab contains most of the parameters and options that you will be concerned with.

Solve For
Solve For
Select the parameter you want to solve for. The parameter you select here will be shown on the vertical axis in the
plots.
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Sample Size N
A search is conducted for the minimum sample size that adheres to the parameter values. Remember that the
search is based on two inequalities, so the particular values of the confidence level and alpha' may not be met
exactly.
Exceedance Margin δ
A search is conducted for the value of δ that meets the requirements of the confidence level and alpha'
inequalities.
α' = Pr(p ≥ P + δ)
α' is the probability that the sample coverage is ≥ P + δ. A search is conducted for the value of α' that meets the
requirements of the other settings.

One-Sided Limit or Two-Sided Interval
Interval Type
Specify whether the tolerance interval is two-sided or one-sided. A one-sided interval is usually called a tolerance
bound rather than a tolerance interval because it only has one limit.
Two-Sided Tolerance Interval
A two-sided tolerance interval, defined by two limits, will be used.
Upper Tolerance Limit
An upper tolerance bound will be used.
Lower Tolerance Limit
A lower tolerance bound will be used.

Sample Size
N (Sample Size)
Enter one or more values for the sample size. This is the number of individuals selected at random from the
population to be in the study.
You can enter a single value or a range of values.

Proportion of Population Covered
Proportion Covered (P)
Enter the proportion of the population that is covered by the tolerance interval. This the desired coverage
proportion between the tolerance limits. It is the probability (area) between the tolerance limits based on the
normal distribution. This is the proportion of the population that lies between the two limits.
If a two-sided interval (L1, L2) is specified, this is the desired area of the probability distribution between L1 and
L2. If F(x) is the CDF of the distribution, P = F(L2) - F(L1).
If a lower limit (L1) is specified, this is the desired area of the probability distribution above L1. If F(x) is the
CDF of the distribution, P = 1 - F(L1).
If an upper limit (L2) is specified, this is the desired area of the probability distribution below L2. If F(x) is the
CDF of the distribution, P = F(L2).
The possible range is 0 < P < 1 - δ. Usually, one of the values 0.80, 0.90, 0.95, or 0.99 is used.
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You can enter a single value such as 0.9, a series of values such as 0.8 0.9 0.99, or a range such as 0.8 to 0.98 by
0.02.
Confidence Level (1 - α)
Specify the proportion of tolerance intervals (constructed with these parameter settings) that would have the same
coverage. The absolute range is 0 < 1 - α < 1. The typical range is 0.8 < 1 - α < 1.
Usually, one of the values 0.90, 0.95, and 0.99 is used.
You can enter a single value such as 0.95, a series of values such as 0.9 0.95 0.99, or a range such as 0.8 to 0.95
by 0.01.

Proportion Covered Exceedance
Proportion Covered Exceedance Margin (δ)
δ is added to P to set an upper bound of P' = P + δ on the coverage. Hence, δ represents a precision value for P.
The value of P' is set to occur with a low probability (0.05 or 0.01).
For example, if P = 0.9 and δ = 0.01, then the parameters are set so that a coverage of 0.9 occurs with high
probability, but a coverage of 0.91 occurs with low probability.
The possible range is 0 < δ < 1 - P. Usually 0.1, 0.05, or 0.01 is used.
You can enter a single value such as 0.02 or a series of values such as 0.01 0.02 0.05 or a range such as 0.01 to
0.05 by 0.01
α' = Pr(p ≥ P + δ)
α' is the probability that the sample coverage p is greater than P + δ. It is set to a small value such as 0.05 or 0.01.
The range is 0.0 < α' < 0.5. Usually 0.1, 0.05, or 0.01 is used.
You can enter a single value such as 0.05, a series of values such as 0.01 0.02 0.05, or a range of values such as
0.01 to 0.05 by 0.01.
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Example 1 – Calculating Sample Size
Suppose a study is planned to determine the sample size required to compute a two-sided 95% normal tolerance
interval the covers 90% of the population. The researcher wants to investigate using a δ of 0.01, 0.025, or 0.05
with an α’ of 0.05.

Setup
This section presents the values of each of the parameters needed to run this example. First load the Tolerance
Intervals for Normal Data procedure window. You may then make the appropriate entries as listed below, or
open Example 1 by going to the File menu and choosing Open Example Template.
Option

Value

Design Tab
Solve For ................................................ Sample Size
Interval Type ........................................... Two-Sided Tolerance Interval
Proportion Covered (P) ........................... 0.9
Confidence Level (1 – α) ........................ 0.95
Coverage Proportion Exceedance (δ) .... 0.01 0.025 0.05
α' = Pr(p ≥ P + δ) .................................... 0.05

Annotated Output
Click the Calculate button to perform the calculations and generate the following output.

Numeric Results
Numeric Results for Two-Sided Tolerance Interval of Normal Data

Confidence
Level
1-α
0.950
0.950
0.950

Sample
Size
N
5910
866
179

Proportion
Covered
P
0.9000
0.9000
0.9000

Proportion
Covered
Exceedance
Margin
δ
0.0100
0.0250
0.0500

P+δ
0.9100
0.9250
0.9500

Pr(p ≥ P + δ)
α'
0.050
0.050
0.050

Tolerance
Factor
k
1.6703
1.7138
1.8084
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Report Definitions
Confidence Level (1 - α) is the proportion of studies with the same settings that produce tolerance intervals with
a proportion covered of at least P.
N is the number of subjects.
Proportion Covered P is the proportion of the population covered. It is the probability between the tolerance
interval limits based on the normal distribution.
Proportion Covered Exceedance Margin δ is the value that is added to P to set an upper bound on the coverage at P +
δ.
P + δ is the upper limit of the proportion covered P. It is a measure of the precision (closeness) of the actual
coverage to P.
α' = Pr(p ≥ P + δ) is the probability that the coverage computed from a random sample (p) is greater than P + δ. It
is set to a small value such as 0.05 or 0.01.
k is the tolerance factor used in calculating the tolerance interval from a sample. The sample tolerance interval
is Mean ± k (SD).
Summary Statements
A two-sided normal tolerance interval computed from a sample of 5910 observations has a target
coverage of 0.900 at a 0.950 confidence level. The probability that the coverage exceeds the
target value by an amount greater than or equal to 0.010 is 0.050. The factor k for computing
the tolerance limit(s) is 1.6703.
Dropout-Inflated Sample Size

Dropout Rate
20%
20%
20%

Sample Size
N
5910
866
179

DropoutInflated
Enrollment
Sample Size
N'
7388
1083
224

Expected
Number of
Dropouts
D
1478
217
45

Definitions
Dropout Rate (DR) is the percentage of subjects (or items) that are expected to be lost at random during the
course of the study and for whom no response data will be collected (i.e. will be treated as "missing").
N is the evaluable sample size at which the tolerance interval is computed. If N subjects are evaluated out of
the N' subjects that are enrolled in the study, the design will achieve the stated tolerance interval.
N' is the total number of subjects that should be enrolled in the study in order to end up with N evaluable
subjects, based on the assumed dropout rate. After solving for N, N' is calculated by inflating N using the
formula N' = N / (1 - DR), with N' always rounded up. (See Julious, S.A. (2010) pages 52-53, or Chow, S.C.,
Shao, J., and Wang, H. (2008) pages 39-40.)
D is the expected number of dropouts. D = N' - N.

This report shows the calculated sample size for each of the scenarios.

Plots Section

This plot shows the sample size versus the three values of δ.
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Example 2 – Calculating α’
Continuing Example 1, the researchers wants to show the impact of various sample sizes on α'. They decide to
determine the value of α' for various value of N between 200 and 1600, keeping the other values the same except
that they set δ to 0.025.

Setup
This section presents the values of each of the parameters needed to run this example. First load the Tolerance
Intervals for Normal Data procedure window. You may then make the appropriate entries as listed below, or
open Example 2 by going to the File menu and choosing Open Example Template.
Option

Value

Design Tab
Solve For ................................................ α' = Pr(p ≥ P + δ)
Interval Type ........................................... Two-Sided Tolerance Interval
N (Sample Size)...................................... 200 to 1600 by 200
Proportion Covered (P) ........................... 0.9
Confidence Level (1 – α) ........................ 0.95
Coverage Proportion Exceedance (δ) .... 0.025

Annotated Output
Click the Calculate button to perform the calculations and generate the following output.

Numeric Results
Numeric Results for Two-Sided Tolerance Interval of Normal Data

Confidence
Level
1-α
0.950
0.950
0.950
0.950
0.950
0.950
0.950
0.950

Sample
Size
N
200
400
600
800
1000
1200
1400
1600

Proportion
Covered
P
0.9000
0.9000
0.9000
0.9000
0.9000
0.9000
0.9000
0.9000

Proportion
Covered
Exceedance
Margin
δ
0.0250
0.0250
0.0250
0.0250
0.0250
0.0250
0.0250
0.0250

P+δ
0.9250
0.9250
0.9250
0.9250
0.9250
0.9250
0.9250
0.9250

Pr(p ≥ P + δ)
α'
0.545
0.287
0.140
0.065
0.029
0.012
0.005
0.002

Tolerance
Factor
k
1.7984
1.7493
1.7287
1.7168
1.7088
1.7029
1.6984
1.6948

This report shows the impact on α' of various sample sizes. Since the value of the Tolerance Factor k is not
related to α' or δ, this report allows you to calculate k for use with sample data.
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Plots Section

This plot shows the sample size versus α'.
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Example 3 – Validation using Guenther (1977)
Guenther (1977) page 174 gives an example in which P = 0.8, 1 – α = 0.9, P + δ = 0.95, and α’ = 0.05. He obtains
a sample size of 26 and a k of 1.613.

Setup
This section presents the values of each of the parameters needed to run this example. First load the Tolerance
Intervals for Normal Data procedure window. You may then make the appropriate entries as listed below, or
open Example 3 by going to the File menu and choosing Open Example Template.
Option

Value

Design Tab
Solve For ................................................ Sample Size
Interval Type ........................................... Two-Sided Tolerance Interval
Proportion Covered (P) ........................... 0.8
Confidence Level (1 – α) ........................ 0.9
Coverage Proportion Exceedance (δ) .... 0.15
α' = Pr(p ≥ P + δ) .................................... 0.05

Output
Click the Calculate button to perform the calculations and generate the following output.

Numeric Results
Numeric Results for Two-Sided Tolerance Interval of Normal Data

Confidence
Level
1-α
0.900

Sample
Size
N
26

Proportion
Covered
P
0.800

Proportion
Covered
Exceedance
Margin
δ
0.150

P+δ
0.950

Pr(p ≥ P + δ)
α'
0.050

Tolerance
Factor
k
1.6124

PASS also calculates the sample size to be 26. The value of k matches to within rounding.
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